程序员の奇妙冒险

返回
Nginx Nginx
2025-04-09 11:57 阅读:179 评论:0

Nginx整合fastdfs问题汇总

一、问题汇总 1、Nginx启动只有master进程而没有worker进程 2、Nginx启动有两个master进程而没有worker进程 3、Nginx启动报: …/storage/trunkmgr/trunkshared.c, line: 194"Permission denied" 4、Ngi

一、问题汇总

1、Nginx启动只有master进程而没有worker进程 2、Nginx启动有两个master进程而没有worker进程 3、Nginx启动报: …/storage/trunk_mgr/trunk_shared.c, line: 194"Permission denied" 4、Nginx启动报:worker process 2396 exited on signal 11 (core dumped) ngx_http_fastdfs_proce

二、解决思路(不分析原因只谈解决方法,这三个问题其实可以做一个问题,因为只要是配置有问题,worker进程就无法正常启动)

1.排查fastdfs-nginx-module模块下的mod_fastdfs.conf文件是否拷贝到了fdfs文件夹下 2.排查fdfs目录下的tracker.conf、storage.conf、mod_fastdfs.conf三个配置文件中的base_path、store_path0、base_path路径下的文件夹是否创建 3.以上两步检测无误后,编辑nginx.conf文件,将#user nobody修改为user root,否则会报…/storage/trunk_mgr/trunk_shared.c, line: 194"Permission denied"即权限问题并且worker进程无法启动 4.以上工作都做完,那么重点来了,在启动Nginx服务前需要首先开启fastdfs服务,唉,说多了都是泪!!!否则就会出现启动了两个master服务,错误日志疯狂刷worker process 9584 exited on signal 11 (core dumped),内存疯狂上升,风扇疯狂转,CPU疯狂升温、以及疯狂秃顶。。。

nginx启动一直报错

1
2
3
4
5
6
7
8
2022/07/26 22:48:12 [notice] 26692#26692: signal 17 (SIGCHLD) received from 27179
2022/07/26 22:48:12 [notice] 26692#26692: signal 17 (SIGCHLD) received from 27179
2022/07/26 22:48:12 [alert] 26692#26692: worker process 27179 exited on signal 11 (core dumped)
2022/07/26 22:48:12 [alert] 26692#26692: worker process 27179 exited on signal 11 (core dumped)
2022/07/26 22:48:12 [alert] 26692#26692: worker process 27179 exited on signal 11 (core dumped)
2022/07/26 22:48:12 [notice] 26692#26692: start worker process 27181
2022/07/26 22:48:12 [notice] 26692#26692: start worker process 27181
ngx_http_fastdfs_process_init pid=27181
  • 查看fastdfs是否启动
  • fastdfs启动命令 /usr/local/bin/fdfs_trackerd /etc/fdfs/tracker.conf /usr/local/bin/fdfs_storaged /etc/fdfs/storage.conf
  • 通过查看fastdfs日志,看主从是否连通
  • 查看防火墙是否关闭,需要关闭防火墙
评论 (0)
暂无评论 来抢沙发吧~